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หวัขอ้ 
2.1 เครื่องมือ 
       2.1.1 ชดุพฒันาโปรแกรมภาษาจาวา 
      2.1.2 การเตรียมซอฟตแ์วร ์
      2.1.3 การติดตัง้ชดุพฒันาโปรแกรมภาษาจาวา 

2.1.4 การติดตัง้โปรแกรม NetBeans 
2.2 เริ่มตน้เขียนโปรแกรมดว้ยเน็ตบีน 
รายละเอียด 

ในการพัฒนาภาษาจาวา เราตอ้งทราบวิธีการเตรียมซอฟตแ์วร ์การติดตัง้โปรแกรม  เพื่อใหเ้ราสามารถเขียน
โปรแกรมภาษาจาวาได ้นอกจากนีเ้ราตอ้งถึง หลกัการตัง้ชื่อในภาษาจาวาและรูปแบบของโปรแกรมภาษาจาวา เพื่อเราจะ
ไดเ้ตรียมตวัและและสามารถเขียนโปรแกรมภาษาจาวาได ้ซึ่งมีรายละเอียดดงันี ้

 
2.1  เคร่ืองมือ 
 เมื่อเราตอ้งการเขียนโปรแกรมภาษาจาวา  เราตอ้งมีการเตรียมซอฟตแ์วร ์ ดงันัน้ เราตอ้งทราบขัน้ตอน ทราบ
วิธีการต่างๆ เพื่อใหส้ามารถพฒันาโปรแกรมภาษาจาวา ได ้ซึ่งมรีายละเอียดดงันี ้
2.1.1 ชุดพัฒนาโปรแกรมภาษาจาวา 

ในการเขียนโปรแกรมภาษาจาวาเราตอ้งมีชดุพฒันาโปรแกรมภาษาจาวา (Java Developer Kit ) หรือชื่อย่อวา่ 
เจดเีค (JDK) ซึง่จะมี จาวาคอมไพลเ์ลอร ์ และจาวาอินเตอรพ์รีเตเตอร ์  ปัจจบุนัมีหลายบรษิัทผลิตชดุโปรแกรมส าหรบั
พฒันาโปรแกรมภาษาจาวา เช่น 

- จาวา เดลเวลลอปเปอร ์คิด (Java Developer Kit )  ของ บรษิัทจาวาซอฟต ์ 
- วิชวล คาเฟ (Visual café) ของ บรษิัทซีแมนเทค 
- เจบวิเดอร ์(J Builder) ของ บรษิัทบอรแ์ลนด ์
- เจเดลเวลลอปเปอร(์JDeveloper) ของ บรษิัทโอราเคิล 
- วิชวล เอจ ฟอร ์จาวา (Visual Age for java) ของ บรษิัทไอบีเอ็ม  
- วิชวล เจพลสัพลสั (Visual J++) ของ บรษิัท ไมโครซอฟต ์

  
 ในการพฒันาจากบรษิัทตา่งๆ เหล่านีม้ีไอดีอี( IDE) ท าใหใ้ชง้านงา่ย มีหนา้จอสวยงาม มีอิดเิตอร ์      มีดีบกั
เกอรซ์ึง่ชว่ยท าใหก้ารเขยีนโปรแกรม  แกไ้ขหรือตรวจสอบขอ้ผิดพลาด ท าไดง้า่ย สวยงามน่าใช ้
 ในการพฒันาภาษาจาวา เราทราบแลว้วา่ ภาษาจาวามีสถาปัตยกรรมที่ส  าคญัอยู่ 4 ส่วน และหน่ึงในส่ีส่วนนัน้
คือ จาวาเอพีไอ ในการเขียนโปรแกรมภาษาจาวาเราตอ้งทราบวา่ จาวาเอพีไอ มีลกัษณะอย่างไรบา้งเพื่อใหเ้ราสามารถ
เลือกใชไ้ดต้รงกบัการท างาน  จาวาเอพีไอมีอยู่ 3 อิดชินั (edition) ดงันี ้

เจทเูอสอี (J2SE) (Java 2 Standard Edition) ใชใ้นการพฒันาโปรแกรมประยกุต ์ (application) หรือแอปเพล็ต 
(applet)  หากการเขยีนโปรแกรมนัน้เป็นโปรแกรมประยกุต ์ เป็นการท างานล าพงั (application standalone) ทางฝ่ังไคล์
เอนต ์

JDK-8.0 ,Netbean IDE 8.0 

ตอนน้ี  JDK-17.0 , Apache Netbean 12.5 

Install ส ำเร็จคือ JDK-11.0 , Apache Netbean 12.5 
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เจทอูีอี (J2EE) (Java 2 Enterprise Edition) ใชใ้นการพฒันางานประยกุตท์างฝ่ังเซิรฟ์เวอร ์เช่น จาวาเซิรฟ์เลต
(Java servlets) และจาวาเซิรฟ์เวอร ์เพจ (JavaServer Pages)  

เจทเูอม็อี (J2ME) (Java 2 Micro Edition)  ใชใ้นการพฒันางานประยกุตส์ าหรบัส าหรบัอปุกรณ ์      โมบาย เช่น
โทรศพัทม์ือถือ 
 ในหนงัสือเล่มนีเ้ราจะกล่าวถึงเจทเูอสอี ซึ่งมีหลายเวอรช์นั เช่น เจทเูอสอี 5.0 บรษิัทซนั  รีลีส (release) แต่ละ 
เวอรช์นัของเจทเูอสอี ดว้ย Java development Toolkit (JDK) ส าหรบั เจทเูอสอี 5.0 Java development Toolkit  เรียกวา่ 
เจดเีค  5.0 ซึง่เทยีบเท่ากบั เจดีเค  1.5 
ปัจจบุนั เจดีเค เวอรช์นัล่าสดุที่ออกมาคือ เจดีเค  8.0   
 เจดเีค  ชดุโปรแกรมพฒันาโปรแกรมภาษาจาวา ส าหรบัการคอมไพล ์ แกไ้ขโปรแกรม เพื่อการท างานแอปพลิเค
ชนัหรือแอปเพล็ต  compile debug run application/applet  ใดๆ เขียนโปรแกรมดว้ยภาษาจาวา  
 

2.1.2 การเตรียมซอฟตแ์วร ์
     การเขยีนโปรแกรมภาษาจาวา เราตอ้งเตรียมซอฟตแ์วร ์ เพื่อช่วยใหเ้ราสามารถเขยีนโปรแกรมได ้ การเตรียมการ
เพื่อเขียนโปรแกรมภาษาจาวา มรีายละเอียดดงันี ้
1).  ในการพฒันาโปรแกรมดว้ยจาวาจะตอ้งมีเครื่องมือช่วยเพื่อพฒันาโปรแกรม   ซึ่งพฒันาโดยบรษิัทซนั ไมโครซิสเต็ม 
เรียกว่า Java 2 Platform System Development Kit (J2SDK) เจดเีค เป็นชดุพฒันาโปรแกรมภาษา จาวา ซึง่เป็นการ
พฒันาที่รวมเอา เอพีไอ และ คลาสไลบราร ีหลกัๆ  แลว้เรียกชื่อวา่  เจทเูอสอ ี

สามารถดาวนโ์หลดไดท้ี่    
http://www.oracle.com/technetwork/java/javase/downloads/index.html 
 
J2SDK เป็นชดุโปรแกรมที่ใชส้  าหรบัสรา้งและพฒันาโปรแกรมภาษาจาวา ภายในชดุประกอบดว้ยโปรแกรมหรือ 

อาจจะใช ้ third-party Java IDE (Integrated Development Environment) ที่มีขาย เช่น เจบิวเดอร ์ (JBuilder) วิชวล 
คาเฟ (Visual Café)  วิชวล เอจ ฟอร ์จาวา ( Visual Age for Java) เป็นตน้  ซึ่ง ไอดีอี เหล่านีจ้ะรวมเครื่องมือในการเขยีน
และพฒันาโปรแกรมไวใ้นรูปของจียไูอ(GUI) ซึ่งมจีอภาพที่สวยงาม ใชง้านไดส้ะดวก ท าใหไ้ม่จ าเป็นตอ้งใชเ้ท็กซอ์ติิเตอร ์
(Text Editor)   
    2). เขียนโปรแกรมดว้ยเท็กซอ์ิติเตอร ์  เป็นแหล่งหรือที่ๆ ที่เราเขียนโปรแกรม ตวัอยา่งโปรแกรมที่เป็นเท็กซอ์ิติ
เตอร ์เช่น โน๊ตเพด (Notepad)  วนิอิดิต (WinEdit)  อิดติพลสั (Edit Plus)   
 การเขยีนโปรแกรมภาษาจาวาเพื่อใหส้ามารถท างานได ้ เราตอ้งก าหนดนามสกลุของซอรส์โคด้ เป็นดอทจาวา
(.java) เมื่อคอมไพล ์โปรแกรม จะไดไ้ฟลไ์บตโ์คด้ ที่มีนามสกลุเป็นดอทคลาส (.class)     จากนัน้เราสามารถสั่งรนั (run) 
โปรแกรมจากไฟลไ์บตโ์คด้ โดยอาศยั เจวเีอ็มในส่วนของเอ็กซค์วิกบัเครื่อง (execution engine) ซึ่งอธิบายไดด้งัรูป 2.4  
การแปลและรนัโปรแกรมภาษาจาวา ซึ่งอธิบายไดด้งันี ้เมื่อเราเขยีนโปรแกรม ชื่อ MyFile.java เราคอมไพลโ์ปรแกรมท าให้
ได ้MyFile.class จากนัน้อินเตอรเ์พส ท าใหไ้ดโ้ปรแกรมที่ท  างานดว้ยภาษาจาวา 
 
 

 

รูปที ่2.4 การแปลและรันโปรแกรมภาษาจาวา 

1101001.. คอมไพล ์
 

อินเตอรเ์พส 
 

 

MyFile.java MyFile.class 
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2.1.3 การติดตั้งชุดพัฒนาโปรแกรมภาษาจาวา  
 จากที่กล่าวมาขา้งตน้ การเขียนโปรแกรมภาษาจาวา เราตอ้งเริ่มจากการเตรียมชุดพฒันาโปรแกรมภาษาจาวา 
โดยเริ่มจากดาวนโ์หลด J2SDK เป็นชุดโปรแกรมที่ใชส้  าหรบัสรา้งและพัฒนาโปรแกรมภาษาจาวา จากนีเ้ราจะท าการ
ติดตัง้เจดีเค 8.0 ซึ่งมีรายละเอียดดงันี ้

เมื่อเราเขา้สู่หนา้เว็บ http://www.oracle.com/technetwork/java/javase/downloadsจะปรากฎหนา้จอดงัรูป  2.1 

 
รูปที ่2.1 เร่ิมตน้การท างานเพือ่ตดิตั้งโปรแกรมเจดีเค 

 

เนื่องจากในท่ีบทเรียนเราตอ้งการท างานกบั NetBean แต่เราตอ้งเตรียม  เจดเีคก่อน ดงันัน้ให ้
1.คลิกที่ ไอคอน Java download java platform (JDK) 8U11 
 .จะปรากฏหนา้จอ ดงัรูป 2.2 เพื่อใหเ้รายอมรบัขอ้ตกลงก่อน  
2.ใหค้ลิก Accept License Agreement      

 
 
 
 
 
 
 
 
 
 
 
 
 

รูปที ่2.2 หน้าจอยอมรับขอ้ตกลง 

1 

2 

http://www.oracle.com/technetwork/java/javase/downloads
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 ที่หนา้จอ License Agreement เมื่อเราคลิก คลิก Accept License Agreement     จะปรากฎดงัรูป  2.3  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

รูปที ่2.3 หน้าจอ เพื่อดาวนโ์หลด เจดเีค 
ที่หนา้จอ 2.3 นี ้เราตอ้งทราบระบบปฏิบตัิการของเครื่องคอมพวิเตอรท์ี่เราก าลงัท างานดว้ย เนื่องจากเครื่องนเีป็นระบบ
ปฎิบตัิการวินโดว ์8   32 บิต ในการติดตัง้นีจ้งึเลือก Windows x86  ดงันัน้คลิกที่ 
3 .Windows x86 File Size 151.81MB Download jdk-8u11 windows-i586.exe 
เมื่อดาวนโ์หลดเสรจ็แลว้ให ้ท าการดาวนโ์หลดตวัอย่างและเอกสารดว้ย คลิกที่ 
4. Windows x86 File Size 54.45 MB Download jdk-8u11 windows-i586-demo.zip 
  
ใน โฟลเดอร ์download จะปรากฏไฟล ์ดงัรูป 2.4 

 
 

รูปที ่2.4 ไฟลท์ีเ่ราดาวนโ์หลด ส าเร็จ 
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 จากที่กล่าวมาขา้งตน้  เราดาวนโ์หลด J2SDK เป็นชดุโปรแกรมที่ใชส้  าหรบัสรา้งและพฒันาโปรแกรมภาษาจาวา  
จากนีเ้ราจะท าการติดตัง้เจดีเค 8.0 ซึ่งมีรายละเอียดดงันี ้
ที่โฟลเดอร ์download ดงัรูป 2.3 
 
 
 

 
 
 

รูปที ่2.5 เร่ิมตน้การติดตั้งเจดเีค 
  
1). ดบัเบิล คลิก  ที่ jdk_8u11-windows_i586    ซึ่งไฟลไ์ทป์เป็น application ขนาด 155449 กิโลไบต ์
ในการติดตัง้จะมีกล่องขอ้ความ User Control Access เนื่องจากจะมีการเปล่ียนแปลงกบัเครื่องคอมพิวเตอรท์ี่ก าลงัติดตัง้
ซอฟตแ์วร ์      เราอนญุาตใหม้กีารเปล่ียนแปลงหรือไม่   ใหเ้ราคลิกปุ่ ม Yes 
จากนัน้จะปรากฏหนา้จอ เป็นตดิตัง้โปรแกรมเจดเีค      ดงัรูป 2.6 
 

 
 

รูปที ่2.6 เร่ิมตน้การติดตั้งโปรแกรม 
2).ใหค้ลิก Next 
   
 
 
 
 
 

1 

2 
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 จะปรากฏหนา้จอ ดงัรูป 2.6  
 
 
 
 
 
 
 
 
 
 
 

รูปที ่2.7 หน้าจอ custom setup 
ที่หนา้จอ 2.7 อธิบายไดด้งันี ้ 
3). หนา้จอ select program ที่ตอ้งการ install  ใหค้ลิก Development Tools 
4).หากตอ้งการเปล่ียน โฟลดเดอร ์ที่จะติดตัง้ ซอฟตแ์วร ์เจดีเค  ใหค้ลิก  Change  
    ในตวัอย่างนี ้เราจดัเก็บไวท้ี่  C:\Program File\Java\jdk1.8.0_11 
5). คลิก  Next           การติดตัง้จะใชเ้วลา สกัครู ่
จากนัน้จะปรากฏหนา้จอ ดงัรูป 2.8 

   
รูปที ่2.8 หน้าจอ runtime environment 

ที่หนา้จอ รูป 2.8   เป็นการติดตัง้ runtime environment 
 6). หากตอ้งการเปล่ียนโฟลเดอรท์ี่จะติดตัง้ซอฟตแ์วร ์เจดเีค ให ้คลิก  Change  จากตวัอย่างนีเ้ราจดัเก็บไวท้ี่ 
C:\Program  Files \Java\jre8 
 7). คลิก Next 

3 

4 

5 

6 

7 
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 จากนัน้จะปรากฏหนา้จอ เพื่อแสดงการติดตัง้โปรแกรม ดงัรูป 2.9   
 
 
  
 
 
 
 
 
 
 
 

 
รูปที ่2.9 หน้าจอ แสดงความก้าวหน้าในการติดตั้งโปรแกรม  

 
จากนัน้จะปรากฏหนา้จอ ติดตัง้เสรจ็สมบรูณ ์   ดงัรูป 2.10    
 8). หนา้จอการตดิตัง้ เจดีเค เสรจ็สมบรูณ ์  คลิก Close 
 
 
 
 
 
 
 
 
 
 
 
 

 

รูปที ่2.10 หน้าจอการตดิตั้งเสร็จสมบูรณ ์    
 
 เมื่อถงึขัน้ตอนนีเ้ราไดท้ าการตดิตัง้ ชดุพฒันาโปรแกรมภาษาจาวาเสรจ็สมบรูณแ์ลว้  ขัน้ตอนต่อไปคือการตดิตัง้
โปรแกรม NetBeans   

 

8 
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2.1.4 การติดตั้งโปรแกรม NetBeans 
การติดตัง้โปรแกรม NetBeans สามารถดาวนโ์หลดไดท้ี่   เว็บไซต ์
https://netbeans.org/downloads/ 
จะปรากฎหนา้จอ ดงัรูป 2.11 

 
 

รูปที ่2.11 หน้าจอเพื่อดาวนโ์หลดโปรแกรม NetBeans 
จากรูป 2.11 ที่ JavaSE 
1). ใหค้ลิก Download 
      ในขัน้ตอนดาวนโ์หลดนีจ้ะใชเ้วลาสกัครู ่ 
เมื่อเราดาวนโ์หลดส าเรจ็  ขัน้ตอนต่อไปคือเราจะท าการตดิตัง้โปรแกรม NetBeans  
ใหเ้ขา้ท างานท่ีโฟลเดอร ์Download ดงัรูป 2.12 
 
 
 

 
 

รูปที ่2.12 โฟลเดอร ์Download 

 
จากรูป 2.12 ท่ีโฟลเดอร ์Download  
2). ดบัเบิล คลิก  ที่ netbeans-8.0-jabase-windows เพื่อตดิตัง้โปรแกรม NetBeans 
     ซึ่ง netbeans-8.0-jabase-windows ซึ่งไฟลไ์ทป์เป็น Application ขนาด 91403 กิโลไบต ์
จากนัน้จะเป็นขัน้ตอนต่างๆ เพื่อการติดตัง้โปรแกรม NetBeans 

1 

2 

https://netbeans.org/downloads/
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การติดตัง้เริ่มที่จอภาพ 2.13 
 

 
รูปที ่2.13 การตดิตั้งโปรแกรม NetBeans 

จากรูป 2.13  
3). คลิก  Next 
จะปรากฏหนา้จอ License Agreement ดงัรูป  2.14  ใหท้ าตามขัน้ตอนดงันี ้
  

3 
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4).คลิก  I accept the terms in the license agreement 
5). คลิก  Next 
 

 
รูปที ่2.14 หน้าจอ License Agreement 

จะปรากฎหนา้จอดงัรูป 2.15 

 
รูปที ่2.15 หน้าจอ JUnit License Agreement 

จากรูป 2.15   ใหท้ าตามขัน้ตอนดงันี ้
6). คลิก I accept the terms in the license agreement. Install JUnit 
7). คลิก  Next 
 

4 

5 

6 

7 
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จะปรากฎหนา้จอดงัรูป 2.16 
 

 
รูปที ่2.16 หน้าจอการก าหนดเส้นทางส าหรับโปรแกรม NetBeans 

จากรูป 2.16   ใหท้ าตามขัน้ตอนดงันี ้
8). ในการติดตัง้โปรแกรม NetBeans เราไดด้าวนโ์หลดไวท้ี่โฟลเดอร ์C:\Program File\NetBeans 8.0  หากไม่ถกูตอ้ง  

คลิก Browse เพื่อเปล่ียนแหล่งที่จดัเก็บ Application ไว ้
9). และเพื่อตดิตัง้โปรแกรม NetBeans เราไดด้าวนโ์หลดโปรแกรม เจดเีค ไวท้ี่โฟลเดอร ์C:\Program 
File\Java\jdk1.8.0_11  หากไมถ่กูตอ้ง  คลิก Browse เพื่อเปล่ียนแหล่งที่จดัเก็บ เจดีเค 
10). คลิก  Next 
 
  

8 

9 

10 
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จะปรากฎหนา้จอดงัรูป 2.17 
 

 
รูปที ่2.17 หน้าจอสรุปเพื่อติดตั้งโปรแกรม NetBeans 

11). คลิก  Install 
จะปรากฎหนา้จอดงัรูป 2.18 
 

 

 
รูปที ่2.18 ก าลังติดตั้งโปรแกรม NetBeans 

ในการติดตัง้จะใชร้ะยะเวลาสกัครู่ 

11 
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 จากนัน้จะปรากฎหนา้จอดงัรูป 2.19 
 

 
รูปที ่2.19 การตดิตั้งโปรแกรม NetBeans ส าเร็จ 

12). คลิก Finish 
  
การติดตัง้โปรแกรม NetBeans ส าเรจ็แลว้ 
 
จากนัน้ท่ีหนา้จอ desktop จะปรากฏ ไอคอนหนา้จอดงัรูป 2.18 

 

 
รูปที ่2.20 ไอคอน โปรแกรม NetBeans 8.0 

 

 หากเราดบัเบิลคลกิที่ไอคอนนี ้จะเขา้สู่โปรแกรมเน็ตบีนเพื่อเขียนโปรแกรมภาษาจาวา 
 
ตอนนีเ้ราไดเ้ตรียมโปรแกรมไวพ้รอ้มแลว้ แต่การเริ่มเขียนโปรแกรมเราตอ้งเรยีนรูร้ายละเอียดต่อไปนี ้

 
 

  

12 
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2.2 เร่ิมต้นเขียนโปรแกรมด้วยเน็ตบีน 
 

ก่อนเขา้สู่โปรแกรม NetBeans   : ใหส้รา้ง folder   NetBeanProjects  เพื่อเก็บ  source code งานท่ีท า  

จากน ัน้ double click เขา้สูโ่ปรแกรม    

2.2.1. Setting up the project 

เริ่มตน้ท างาน Project        
To create an IDE project: 

1.Start NetBeans IDE.    

 อธิบายจอภาพของ Netbeans IDE 7.3 หนา้จอแรก  Start Page 

 

 

2.In the IDE, choose File > New Project (Ctrl-Shift-N), as shown in the figure below.  
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3. In the New Project wizard, expand the Java category and select Java Application as shown in 

the figure below. Then click Next.  

 

 
4. In the Name and Location page of the wizard, do the following (as shown in the figure below):  

4.1 - In the Project Name field, type Chap01.    :  พมิพช์ือ่ Project 

4.2 - specify project location   : ระบแุหลง่ทีเ่ก็บ  จากตัวอยา่งเก็บ Project ใน folder  

          E:\DDrive\204219\ProgT1Y57  click Browse.. 

4.3 - In the Create Main Class ,click      chap01.Chap01 chap01 คอื ชือ่ package 

 

5. Click Finish.  

4.1 

4.2 

4.3 

 5 
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The project is created and opened in the IDE. You should see the following components:  

• The Projects window, which contains a tree view of the components of the project, including 

source files, libraries that your code depends on, and so on.  

• The Source Editor window with a file called Chap01 open.  

• The Navigator window, which you can use to quickly navigate between elements within the 

selected class.  

 

----------------------------------------------- 

 
การเริ่มเขียนโปรแกรม เราจะเรียนหนา้จอของ NetBeans ก่อนวา่แต่ละส่วนเรียกวา่อะไร 
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The GUI Builder's various windows include:  
• Design Area. The GUI Builder's primary window for creating and editing Java GUI forms.  

The toolbar's Source and Design toggle buttons enable you to view a class's source code or a graphical view 
of its GUI components. The additional toolbar buttons provide convenient access to common commands, 
such as choosing between Selection and Connection modes, aligning components, setting component auto-
resizing behavior, and previewing forms.  

• Inspector. Provides a representation of all the components, both visual and non-visual, in your 
application as a tree hierarchy. The Inspector also provides visual feedback about what component in the 
tree is currently being edited in the GUI Builder as well as allows you to organize components in the available 
panels.  

• Palette. A customizable list of available components containing tabs for JFC/Swing, AWT, and 
JavaBeans components, as well as layout managers. In addition, you can create, remove, and rearrange the 
categories displayed in the Palette using the customizer.  

• Properties Window. Displays the properties of the component currently selected in the GUI Builder, 
Inspector window, Projects window, or Files window.  

 

 

Design Area 
Properties 

Window 

Inspector 

Palette 
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2.2.2. Adding Code to the Generated Source File 

Because you have left the Create Main Class checkbox selected in the New Project wizard, the IDE has 

created a skeleton class for you. You can add the "Hello World!" message to the skeleton code by 

replacing the line:  

// TODO code application logic here 

with the line:  

System.out.println("Hello World!"); 

Save the change by choosing File > Save. 

The file should look something like the following: 

/* 

/* 

 * To change this template, choose Tools | Templates 

 * and open the template in the editor. 

 */ 

package chap01; 

/** 

 * 

 * @author Comscience 

 */ 

public class Chap01 { 

    /** 

     * @param args the command line arguments 

     */ 

    public static void main(String[] args) { 

            System.out.println("Hello World!"); 

    } 

} 

2.2.3. Compiling the Source File 

To compile your source file, choose Build > Build Main Project (F11) from the IDE's main menu.  

You can view the output of the build process by choosing Window > Output > Output. 

The Output window opens and displays output similar to what you see in the following figure. 
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If the build output concludes with the statement BUILD SUCCESSFUL, congratulations! You have 

successfully compiled your program! 

If the build output concludes with the statement BUILD FAILED, you probably have a syntax error in 

your code. Errors are reported in the Output window as hyper-linked text. Click such a hyper-link to 

navigate to the source of an error. You can then fix the error and once again choose Build > Build Main 

Project. 

When you build the project, the bytecode file Chap01.class is generated. You can see where the new 

file is generated by opening the Files window and expanding the Chap01/build/classes/Chap01 

node as shown in the following figure. 

 

Now that you have built the project, you can run your program.  

2.2.4. Running the Program 

From the IDE's menu bar, choose Run > Run Main Project (F6). 

The next figure shows what you should now see. 

 

 

Congratulations! Your program works!  

You now know how to accomplish some of the most common programming tasks in the IDE. 
 
 
 


