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Week 2

Web Authoring Tools:
Google Sites

I By Dr. Jakarin Chawachat

Adapted to English by Prakarn Unachak

Department of Computer Science, Faculty of Science, Chiang Mai University

What is Google Sites?

» A service provided by Google
» Tool for Create and Display Website

» Web Host
» Part of Google Apps Productivity Suite
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Examples: Google Sites Websites
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The Fresh Site by SitesTemplate.net

InterlocklT.com
www.petitsgateaux.gr
www.vandrew.com
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What can Google Sites do for us?

» Easy to create new pages

» With just one button click

No need to know about HTML
Multiple layout choices

v v v

Many Templates available

v

Possible to upload and shares many types of contents
» Calendar, spreadsheet, video...

Allow Collaborations

v v

Can limit/allow access for different people
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Google Sites Program Policy

» Nudity and Sexually Explicit Material

Sexually explicit materials must be marked (‘Containing Mature
Contents’)

No commercial pornography

No content that promotes pedophilia, incest of bestiality
» Violence

No direct threats of violence

No graphic violence contents
» Hateful Speech Against Protected Groups

No material that promotes hatred toward groups of people
based on their race or ethnic origin, religion, disability, gender,
age, veteran status, or sexual orientation/gender identity.
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Google Sites Program Policy (2)

» Impersonation

No impersonation of others that is intended to or does mislead or
confuse others.

» Private and Confidential Information

No unauthorized publishing of people's private and confidential
information

Credit card numbers, Social Security Numbers, driver's, other license
numbers, and other personal information

» Commercial Activity

» Websites for business or to promote products or services are
allowed

» No websites that exist primarily to redirect user to another
commercial websites

» No sites that exist only to display ads
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Google Sites Program Policy (3)

» Copyright
No sites that violate copyright
» Unlawful Use of Service

No sites that are for unlawful purposes or for promotion of
dangerous and illegal activities

» Drugs

No promotion or sale of regulated or illegal pharmaceutical
substances

Or for any substances that mimic the effects of illegal or regulated
drugs

» Spam, Malware and Phishing

No transmission of malware and viruses or anything that may disrupt
this service or harm our users

From  http://www.google.com/sites/help/intl/en/program_policy.html
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Getting Start e

I. Register for a Google 0
Account

2. Go to sites.google.com

3. Signin
; T
4. You should be at Sites =
page. Gougle | o Y
- @ ;
=2 Vi) Use Sites to
8 204100 Information Technology and Modern Life | :Web Authoring Tools

12/02/59



Creating a Site

» Click on IEZE button to create a new website
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9 204100 Information Technology and Modern Life | :Web Authoring Tools

Creating a Site (2)

Select ATemplate

We'll use Blank Template for
this one

Name your site
Choose the URL
Select a Theme
Font & Background
More Option
Description

Mature Content tag

Check I'm not a robot
Click the button
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Choosing URL for your Site

» Not a duplication of existing site
» Not a Gmail username
Except your own

» Only allow the following characters
A-Z
a-z

0-9
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Our First Google Site

» Name: CMU 204100 English Demo

» URL:cmu204100englishdemo

L L

Mot Vet

googhecom 1

(sttirsg Seastedd Tha frackuts Schocl o... () Sefrwarn Carpestry

Home  usetesses

CMU 204100 English Demo

e Home

Stemap

Brogramming A Fany - W,

Bearch this aite

Rucert Sitw dstiafy | Raport Aboms | Frivk Fage | Awmove Aocems | Resred @y Gongle Sites

204100 Information Technology and Modern Life | :Web Authoring Tools

12/02/59



Editing the Page

¢ s s Em

» Click on the Pencil button at top right corner to edit the page
» You will go to edit mode

Home anoet
poet Fomat Tnble Layost teip

CMU 204100 English Demo Snarch this ste
e Home

» After you have finish edit the content, click BEESlto save
the changes onto the page.

Editing the Page (2)

» In the edit mode, additional toolbar become available:

Inset Format Table Layout Help
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Formatting
. Format | Table Layout Help
» Clear Formatting
1 Ix Clear Formatting Ctrl+\
» Assign Headings ——— s
Sub-heading (H3) Chri+At+3
s il ! } Minor heading (H4) Ctri+Alt+4 |
v Normal paragraph text  Cirl+Alt+0
super, 1 1
» Set text to SUPe'script or ( script . R
» Set Text Alignment 7 Sepersenn o
x  Subscript Ctrl+
Left -
Center Blockquote Code
. Align left Ctrl+Shift+L
Right
Align center CHri+Shift+E |
= Align right Cirl+Shift+R
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v~ Normal - spt B 7 U A I |ea|i= = = | Ix am
The toolbar has the following tabs
» Insert
Adding objects and applications
» Format
Formatting the text
» Table
» Layout
Adjust web page layout (how contents are organized)
» Help
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Tables
» Insert table Table | Layout  Help
» Insert row Insert table >
» Insert column Insert row above
Insert raw below
» Delete table et pee
Insert column on the left
» Delete row
Insert column on the right
» Delete column
Delete table
Delete row
Delete column
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Layout

Layout | el Change Layout of the current page
I One column (simple)

Bl Two column (simple)

I Three column (simple)

= One column

Two column

v I | eft sidebar o Home
i Right sidebar

imi | eft and right sid
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Three coumn - CMU 204100 English Demo search this ate

Insert Menu

Many objects can
be added into a
web page

v

Images
» Links
Table of contents

v

YouTube video

v v

Map
+1 button

v

Insert | Format Table Layoun Help

B -8B
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Inserting an Image

» Insert an image by clicking at =l m=: option under Insert
tab.

» Add an Image window will appear

» Select an image from Add an Image

Your PC (Uploaded)

The Internet (URL) @ Uploadad IMagss  ypioas images
» Fill Alt Text

Alt text [optional)
» Click OK to insert the image

Cancel

» You can then adjust the image
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Adjusting the Image

= | & | | s | m | L 100% Original

» Alignment
Left/Center/Right
» Size

= | X

Small/Medium/Large/100%/Original

» Wrap with text
On/Off

» Remove image

Wrap On Wrap Off
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Create a new Page

» Click the new page button
» Then, name your page

» Then, select page type
(template)

MHame your page:
elcs204 change URL

Select a template to use (Learn maore)

Web Page =

21 204100 Information Technology and Modern Life | :Web Authoring Tools

Inserting a Link

» Highlight text/Select object you want to insert the link
» Select Insert tab — eo Link
» You can insert link from

. Sitemap My Recent Changes
Sltes Page E CMU 204100 English Demo
Within the same Site Home
TestPagel
Web address

Text to display:
Use URL to go to outside webpage

Link to this URL:

Example: www.google.com
Check/Uncheck Open this link in a new window
Click OK to create the link Cipen this ik in @ naw wndow

“ . Fancel
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Inserting a Table of Contents

» Table of Contents help us navigate a large page with
multiple headings. It contains links to headings and
subheadings within the page

» First, we create:

Heading

sub-heading
£ minor-heading

To the headings we want, then we insert Table of
Contents

» Google Site will then automatically create Table of
Contents from headings

23 204100 Information Technology and Modern Life | :Web Authoring Tools

Inserting a Table of Contents (2)

Heading 1 Contents

e

Table of Content

Minar Fanding 1.1.1

*  You can view the table of
contents after you exit edit

Minar Hending 1.1,3 mode.

i . *  When you add/remove
headings later on, table of
contents will update as well.
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Inserting a Subpage Listing

» Create links to other subpages within the Site

Insert Subpage Listing

Te: [ ST

Show subpages of:
& the cument page: home
top el
chagge 3 page

Show bavels: |2 *

Wideh: 250 pixels

Bppearance:
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Inserting Horizontal Line and +1 Button

tExt tENt Pewt Dext text bext TeNt text tes

» Horizontal Line help with
organizing your page

» +1| Button allow the user to
endorse a page.
» Similar to |£J tike |button on
Facebook, but you can add

comments.
» You can only add +1 button
on public page. o1
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Inserting YouTube Videos

» Insert — YouTube (3" column)
» Paste video URL in the URL Box, the clickm

FF .
Simi5ayyes m
Capybara with Guines Pigy

g
Dinpley

Vidsy sz | 250070 v
# Inclade bardes

# Inchide it ot

Inserting a Map

» Insert > Map T e s
» Select a Location g 2] =
Using Map B %

Type into search bar
Paste Google map link 0

to the address bar ¥ o
below the map
» Use Drop a placemark to
get the exact location
 Click [
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Insert Other Objects

» Calendar
Google Account calendar
» Charts
Build chart from spreadsheet
» Files in Google Drive
» Google+
Photo, Photo Album, Post
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Changing Background

» Select - — Manage Site
» Select Theme, Colors and Fonts

» Change Background from
Color bucket
Image

» You can also change color to other parts of the page
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Creating a new Page

» Click New Page button

» Name the new page

» Select a template (page
type)

» Pick the location of the

page Seiect ,u.-—.fm to use {Lesm more)

» Click Create o

Hame your page

Subsct 3 location
& Pul page 2 the top kel
Put page undar Homa

* Chotss = diferen lpcation
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Page Types

» When you create a new page, there are a
few templates you can choose:

Web Page
Announcements
File Cabinet
List
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Web Page

» Simplest of the templates

» Can freely add in contents
Type in text contents
Insert other objects

» Edit like Words Document
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Announcements

CMU 204100 English Demo

» Like a blog

Test Announcement

» Click WMewpost toadda
new post =~ iy

» Each post is an individual
page

Hute werld)
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File Cabinet

» Store and organize files, make it easy to share with others

+ add file + add link 45 add fram Drive | Moveto - W Delete & Subscribe to changes
4 minutes ago Prakam Unachak
Test Form a minute ago Prakarn Unachak
Test Form {Responses  minute ago Prakarn Unachak
Secrets (R
Lab03 - Goople Form.docx a minuts aga Prakam Unachak
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File Cabinet (2)

» Add file to your Cabinet
From your PC (+Add file)
From URL (+Add link)
From Google Drive (+ From drive)
» Folder
Move to — New Folder to create a folder

Check the checkbox in front of a file and select Move to will
move the file there

» To remove a file, check the checkbox and select Delete
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List

» Collect and Organize Data into a table
» Can use template or create your own table

» Insert data as items make it easy to add, edit and remove
» The viewer can sort the data to their liking

Get started creating a list using one of our list templates or create your own

Action Ttems Issue List Unit Status Create your own
Keep track of action items Track your project's open Track the status of individual | Define your own columns for
from a meeting or project issues units in your project your list
Use template Use template Use template Use template
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List (2)
» If you choose Create your own, Customize your list windows
will appear

» Choose column

Customize your list

name o ;
Customize yous list by adding and configuring columne,
4 Choose Data t)’pei ColumnsiFialds to Coflect ColunnFisld Details
»  Checkbox Name Column name:
Shudent i) e
»  Dropdown By
Like Panda? Type:
» Date = e —
»  Text
Sarting
> URL Fustsathy ¢ v ® Ascendng  Descending
3 Add anoer o b
» Click Save =8
Cancel
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List (3)
» Select Add Item
» Fill in items

TestList
Add item Customize this lst Showing 3 items
Name Student ID Birthday Like Panda? Cat or Dog?
Niranam Ralsakul Monday, September Mouse
1, 2014
Joe Somabody onday, September Dog
2, 1996
Tina Turner Thursday, February Cat
22, 1979
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Page Settings

» Goto ©- — Page settings
Page actions
Revision History

Subscribe to page changes
Page settings

& Print page

[} Copy page

Move page

» You can set
Show/hide page title
Allow comments

Cunwally usng parge Inslain Flln Coblnet (Chimige

Change page URL o

Change template
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Deleting a Page

» Go to the page you want to delete
» Select ©-
» Select Delete Page
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Sharing the Site
» Click [EEEat the top-right corner of the page

@ Public on the web

Anyone on the Intemet can find and access.
No sign-in required

» Then either copy the link, or select the social media of

your choice
Link to share
hitps isites google comysite/cmu204 10 Dengishdemal
] v
&
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Setting Permissions
» Click [ at the top-right corner of the page

y 0 -

& Public on the web

Anyone on the Intemet can find and access.
No sign-in required.

» The click Change... under Who has access area

© Public on the web - Anyone on the Internet

3 Change
can find and view g
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Setting Permissions (2)

» You can then change visibility level of the Site

» For Specific People = & TR i
level, they need to o
. . L3 Anyone with the link
sign in. 5 Anyone who has the link can access. No sign-in required
» After you have set & Specific people
Shared with specific
the visibility level
you want, Cllen Access 5 : Can view
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Page acticns

Preview Page as a Viewer

» After you have developed the Site o
and wish to view the Site as a &
viewer, do the following:

|. Select =x- Prevew pige as vewer

2. Select Preview page as viewer P ciplansh
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Deleting a Site

» To delete a Site, Click on =- then select Manage Site

Site actions

Subscribe to site changes
Edit site layout
Manage site

&+ Sharing and Permissions

» Under Manage Site page, select Delete this site

Site storage

0% of 100 MB used
Copy this Site Publish this site as a template Delete this Site
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Deleting a Site (2)

» You will get a confirmation window, click DELETE

Delete site "wd205116u™7

9d, but you can restors it by wsiting its URL

Are you sure yau want ta cantrue?

m et
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